VMware Converter 5.0 and vSphere 5.1 Workaround

Came across this issue the other day when attempting to P2V a system into a vSphere 5.1 cluster. Apparently there is an issue with using VMware converter 5.0.0 (build 470252) and importing either a physical machine or virtual machine to vSphere 5.1. The “issue” is that your converter client will crash!  This is pointed out in VMware Knowledge Base article 2033315.

This happens if you target either an ESXi 5.1 host or vCenter 5.1

I’ve heard people using the 4.3 version of converter to “get around” this problem for now until they update the release, but that involves a few extra steps and you loose the benefit of aligning your vDisks when converting. A few things to remember if you use this workaround.

  • Use hardware version 4, 7 or 8 when doing the conversion
  • Manually upgrade the virtual machine (once imported) to version 9 with the web client

I am willing to bet that they will be releasing a new converter build soon to fix this issue, but until then this is your workaround.

Rick

One comment

Leave a Reply