Cisco UCS Manager and Java Issues

As much as I love Java development, I am constantly annoyed by Java updates on a workstation and getting the right version of Java to work on a product. The Cisco UCS Manager is no different an thus prompted me to post this in an attempt to remediate the issue that I can only image a lot of people have with accessing the management interface.

I downloaded the latest and greatest Java version and build which was version 7 update 5 at the time of this writing. My workstation wasn’t running this, so I found the link on the main page of the UCS Manager.

I thought to myself – great! They have a link to the latest and greatest Java and immediately downloaded version 7 update 5. Alas, much to my displeasure, I was presented with this error when attempting to connect to one of the fabric interconnects.

What the…. According to the error message was was to be a 1.6 update 10 or higher! Thinking that there must be something wrong with the version that I just downloaded and installed, I immediately removed Java and reinstalled after a reboot of Windows 7. Well, that didn’t produce results and I stared to look on the Cisco forums for answers. One of the suggestions called for a modification of the way Java keeps and removes temporary files, but that did not resolve the issue and I continued to receive the error above.

On a hunch – I removed all versions of Java that were installed on my computer at the time:

I then restarted and installed the old version of Java which is Version 6 Update 33 and that resolved it.

After finding the resolution, I like to do some research in my spare time to determine the root cause of the issue and managed to locate this link on Cisco’s site. It pertains to the 2.0 platform and talks about the need for Java 1.6  due to the “lack of 64bit native libraries for the KVM/VMedia. Still doesn’t fully explain the Java runtime error that I received stating that anything higher will work.

Hope this helps those that are trying to get in and administer the UCS environment.

Rick

 

2 comments

  1. Dan

    Wow Rick thanks for posting this, unfortunately our company has a policy to make sure we have the latest Java version so this continues to plague me as well as I need a different version of Java for another app so I am totally hosed at every pass. I will try removing all and starting over to see what happens. Not sure why Cisco will not fix this issue. Drives me crazy…

  2. Malvin

    You can resolve this by using Oracle’s Java Deployment Rule Set. This will allow you to have multiple versions of Java installed and assign a version per application, so you’d be able to run the Cisco software on the web browser using 1.6 and still have 1.7.40 or higher for everything else.

Leave a Reply